RenderSchedule.TimelineBuilder Class

Used as part of a RenderSchedule.ScriptBuilder to define a RenderSchedule.Timeline.

see RenderSchedule.ElementTimelineBuilder and RenderSchedule.ModelTimelineBuilder.

Extended by

Methods

Name Description
constructor(): RenderSchedule.TimelineBuilder    
addColor(time: number, color: undefined | RgbColor | { blue: number, green: number, red: number }, interpolation: RenderSchedule.Interpolation = Interpolation.Linear): void Append a new RenderSchedule.ColorEntry to the timeline.  
addCuttingPlane(time: number, plane: undefined | { direction: Readonly<WritableXYAndZ>, hidden?: boolean, position: Readonly<WritableXYAndZ>, visible?: boolean }, interpolation: RenderSchedule.Interpolation = Interpolation.Linear): void Append a new RenderSchedule.CuttingPlaneEntry to the timeline.  
addTransform(time: number, transform: undefined | Transform, components?: { orientation: Point4d, pivot: Readonly<WritableXYAndZ>, position: Readonly<WritableXYAndZ> }, interpolation: RenderSchedule.Interpolation = Interpolation.Linear): void Append a new RenderSchedule.TransformEntry to the timeline.  
addVisibility(time: number, visibility: undefined | number, interpolation: RenderSchedule.Interpolation = Interpolation.Linear): void Append a new RenderSchedule.VisibilityEntry to the timeline.  
finish(): RenderSchedule.TimelineProps Obtain the JSON representation of the RenderSchedule.Timeline produced by this builder.  

Properties

Name Type Description
color undefined | RenderSchedule.ColorEntryProps[] Timeline controlling color.  
cuttingPlane undefined | RenderSchedule.CuttingPlaneEntryProps[] Timeline controlling clipping.  
transform undefined | RenderSchedule.TransformEntryProps[] Timeline controlling position and orientation.  
visibility undefined | RenderSchedule.VisibilityEntryProps[] Timeline controlling visibility.  

Defined in

Last Updated: 11 June, 2024