RenderSchedule.ScriptReference Class

A reference to a RenderSchedule.Script indicating the persistent Element from which the script was obtained. Prior to the introduction of the RenderTimeline class in version 01.00.13 of the BisCore ECSchema, scripts were stored in the JSON properties of DisplayStyle elements. Now they are stored in the Script property of a RenderTimeline element. The sourceId can refer to either a DisplayStyle or a RenderTimeline.

Methods

Name Description
constructor(sourceId: string, script: RenderSchedule.Script): RenderSchedule.ScriptReference    

Properties

Name Type Description
script Readonly RenderSchedule.Script The script.  
sourceId Readonly string The Id of the RenderTimeline or DisplayStyle element that hosts the script.  

Defined in

Last Updated: 11 June, 2024