clone Method

Create a copy of this MapLayerSettings, optionally modifying some of its properties.

clone(changedProps: MapLayerProps): MapLayerSettings

Parameter Type Description
changedProps MapLayerProps JSON representation of the properties to change.

Returns - MapLayerSettings

A MapLayerSettings with all of its properties set to match those of this, except those explicitly defined in changedProps.

Defined in

Last Updated: 11 June, 2024