onTransformElement MethodProtected

Transform the specified sourceElement into ElementProps for the target iModel.

onTransformElement(sourceElement: Element): ElementProps

note A subclass can override this method to provide custom transform behavior.

Parameter Type Description
sourceElement Element The Element from the source iModel to transform.

Returns - ElementProps

ElementProps for the target iModel.

Defined in

Last Updated: 11 June, 2024