areAvailable Method

Beta  

Check to see if all of the specified codes are available to be reserved.

areAvailable(requestContext: AuthorizedClientRequestContext, codes: CodeProps[]): Promise<boolean>

Parameter Type Description
requestContext AuthorizedClientRequestContext The client request context
codes CodeProps[] the list of codes to be reserved.

Returns - Promise<boolean>

true if all codes are available or false if any is not.

Defined in

Last Updated: 11 June, 2024