withPreparedStatement Method
Use a prepared ECSQL statement, potentially from the statement cache. If the requested statement doesn't exist in the statement cache, a new statement is prepared. After the callback completes, the statement is reset and saved in the statement cache so it can be reused in the future. Use this method for ECSQL statements that will be reused often and are expensive to prepare. The statement cache holds the most recently used statements, discarding the oldest statements as it fills. For statements you don't intend to reuse, instead use ECDb.withStatement.
withPreparedStatement<T>(ecsql: string, callback: (stmt: ECSqlStatement) => T): T
Parameter | Type | Description |
---|---|---|
ecsql | string | |
callback | (stmt: ECSqlStatement) => T | the callback to invoke on the prepared statement |
Returns - T
the value returned by callback
.
Defined in
- core/backend/src/ECDb.ts Line 155
Last Updated: 11 June, 2024