IModelsHandler Class
Handler for managing HubIModel instances. Use IModelHubClient.IModels to get an instance of this handler.
note Use IModelHubClient.IModel for the preferred single iModel per context workflow.
Methods
Name | Description | |
---|---|---|
delete(requestContext: AuthorizedClientRequestContext, contextId: string, iModelId: string): Promise<void> | Delete an iModel with specified id from a context. | |
get(requestContext: AuthorizedClientRequestContext, contextId: string, query: IModelQuery = ...): Promise<HubIModel[]> | Get iModels that belong to the specified context. | |
update(requestContext: AuthorizedClientRequestContext, contextId: string, imodel: HubIModel): Promise<HubIModel> | Update iModel's name and/or description |
Defined in
Last Updated: 11 June, 2024