createFaceLoopFromCoordinates MethodStatic

create a circular doubly linked list of internal and external nodes from polygon points in the specified winding order

  • This applies the masks used by typical applications:
    • HalfEdgeMask.BOUNDARY on both sides
    • HalfEdgeMask.PRIMARY_EDGE on both sides.
  • Use createFaceLoopFromCoordinatesAndMasks for detail control of masks.

createFaceLoopFromCoordinates(graph: , data: LineStringDataVariant, returnPositiveAreaLoop: boolean, markExterior: boolean): undefined |

Parameter Type Description
graph  
data LineStringDataVariant  
returnPositiveAreaLoop boolean  
markExterior boolean  

Returns - undefined |

Defined in

Last Updated: 11 June, 2024