collectExtendedBoundaryLoopsInGraph MethodStatic

Collect arrays of nodes "around the boundary" of a graph with extraneous (non-boundary) edges.

  • The "boundary" is nodes that do NOT have the exterior mask, but whose mates DO have the exterior mask.
  • After each node, the next candidate in reached by looking "around the head vertex loop" for the next boundary.
    • "Around the vertex" from nodeA means
      • First look at nodeA.faceSuccessor;
      • Then look at vertexPredecessor around that vertex loop.
  • Each accepted node is passed to announceNode, and marked with the visit mask.

collectExtendedBoundaryLoopsInGraph(graph: , exteriorMask: ): [][]

Parameter Type Description
graph  
exteriorMask  

Returns - [][]

Defined in

Last Updated: 11 June, 2024