collectConnectedComponentsWithExteriorParityMasks MethodStatic

Collect arrays gathering faces by connected component.

collectConnectedComponentsWithExteriorParityMasks(graph: , parityEdgeTester: undefined | HalfEdgeTestObject, parityMask: = HalfEdgeMask.NULL_MASK): [][]

Parameter Type Description
graph graph to inspect
parityEdgeTester undefined | HalfEdgeTestObject (optional) function to test of an edge is a parity change.
parityMask (optional, along with boundaryTestFunction) mask to apply indicating parity. If this is Mask.NULL_MASK, there is no record of parity.

Returns - [][]

Defined in

Last Updated: 11 June, 2024