sweepToUnionOfConvexClipPlaneSets Method

Triangulate the region. Create a UnionOfConvexClipPlaneSets that clips to the swept region.

  • If sweepVector is not given, the sweep direction is perpendicular to the plane of the contour.
  • If sweepVector is given, it is the sweep direction and does not have to be perpendicular to the contour.
  • cap0 and cap1 indicate construction of clip planes parallel to the contour plane.
  • If cap1 is true, the cap plane is at anyPointOnPlane + sweepVector. That is, the sweep vector indicates both direction and distance.
  • caps are NOT created of sweepVector is not given.

sweepToUnionOfConvexClipPlaneSets(sweepVector?: Vector3d, cap0: boolean = false, cap1: boolean = false): undefined | UnionOfConvexClipPlaneSets

Parameter Type Description
sweepVector Vector3d  
cap0 boolean  
cap1 boolean  

Returns - undefined | UnionOfConvexClipPlaneSets

Defined in

Last Updated: 11 June, 2024