clonePartialCurve Method

Return (if possible) a LineString which is a portion of this curve.

  • This implementation does NOT extrapolate the linestring -- fractions are capped at 0 and 1.

clonePartialCurve(fractionA: number, fractionB: number): undefined | CurvePrimitive

Parameter Type Description
fractionA number start fraction
fractionB number end fraction

Returns - undefined | CurvePrimitive

Defined in

Last Updated: 11 June, 2024