createFromLengthAndRadius MethodStatic

Create (if possible) a DirectSpiral3d, applying various strict conditions appropriate to the spiral type. The parameter list includes extraneous values in order to directly match IntegratedSpiral3d.create, which has greater flexibility about mixtures of values.

  • IMPORTANT RESTRICTIONS
    • Direct spirals must have the inflection at the origin of their coordinate system, aligned with the x axis.
      • hence bearing0 = 0
      • hence radius0 = 0
    • bearing1 is ignored
    • radius1 must be given.
    • arcLength must be given,

createFromLengthAndRadius(spiralType: string, radius0: undefined | number, radius1: undefined | number, bearing0: undefined | Angle, _bearing1: undefined | Angle, arcLength: undefined | number, activeInterval: undefined | Segment1d, localToWorld: Transform): undefined | TransitionSpiral3d

Parameter Type Description
spiralType string one of the types in DirectSpiralTypeNames
radius0 undefined | number radius (or 0 for tangent to line) at start. Must be ZERO or UNDEFINED
radius1 undefined | number radius (or 0 for tangent to line) at end.
bearing0 undefined | Angle bearing, measured CCW from x axis at start. Must be ZERO or UNDEFINED
_bearing1 undefined | Angle  
arcLength undefined | number  
activeInterval undefined | Segment1d  
localToWorld Transform placement transform

Returns - undefined | TransitionSpiral3d

Defined in

Last Updated: 11 June, 2024