collectCurvePrimitivesGo Method

Return an array containing only the curve primitives.

  • This DEFAULT simply pushes this to the collectorArray.
  • CurvePrimitiveWithDistanceIndex optionally collects its members.

collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], smallestPossiblePrimitives: boolean): void

Parameter Type Description
collectorArray CurvePrimitive[] array to receive primitives (pushed -- the array is not cleared)
smallestPossiblePrimitives boolean if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children.

Returns - void

Defined in

Last Updated: 11 June, 2024