create MethodStatic

Create a bspline with given knots.

  • Two count conditions are recognized:

** If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping. ** If poleArray.length + order == knotArray.length + 2, the knots are in modern form.

create(poleArray: Point3d[] | Float64Array, knotArray: number[] | Float64Array, order: number): undefined | BSplineCurve3d

Parameter Type Description
poleArray Point3d[] | Float64Array  
knotArray number[] | Float64Array  
order number  

Returns - undefined | BSplineCurve3d

Defined in

Last Updated: 11 June, 2024