constructor Method

Initializes a new FormatDiagnosticReporter

FormatDiagnosticReporter(suppressions?: Map<string, string[]>, i18n?: I18N): FormatDiagnosticReporter

Parameter Type Description
suppressions Map<string, string[]> A Map where the key is a schema full name and the value is collection of diagnostic codes to suppress.
i18n I18N The I18N instance to use to translate validation messages.

Returns - FormatDiagnosticReporter

Defined in

Last Updated: 11 June, 2024