constructor Method

Construct a new LRUDictionary to hold up to limit entries.

LRUDictionary<K, V>(limit: number, compareKeys: OrderedComparator<K, K>): LRUDictionary<K, V>

Parameter Type Description
limit number The maximum number of entries permitted in the dictionary.
compareKeys OrderedComparator<K, K> The function used to compare keys within the dictionary.

Returns - LRUDictionary<K, V>

Defined in

Last Updated: 11 June, 2024