WidgetDef Class
A Widget Definition in the 9-Zone Layout system.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(widgetProps: WidgetProps): WidgetDef | ||
canOpen(): boolean | ||
getWidgetControl(type: ConfigurableUiControlType): WidgetControl | undefined | ||
setLabel(v: string | StringGetter): void | Set the label. | |
setTooltip(v: string | StringGetter): void | Set the tooltip. | |
setUpSyncSupport(props: WidgetProps): void | ||
setWidgetState(newState: WidgetState): void | ||
initializeFromWidgetProps(widgetProps: WidgetProps, me: WidgetDef): void Static |
Properties
Name | Type | Description | |
---|---|---|---|
activeState Accessor ReadOnly | WidgetState | ||
applicationData | undefined | any | ||
badgeType | undefined | BadgeType | ||
betaBadge | undefined | false | true | Deprecated | |
classId | string | ConfigurableUiControlConstructor | undefined | ||
fillZone | boolean | ||
iconSpec | string | React.ReactNode | ||
id | string | ||
isActive Accessor ReadOnly | boolean | ||
isFloating | boolean | ||
isFloatingStateSupported | boolean | ||
isFloatingStateWindowResizable | boolean | ||
isFreeform | boolean | ||
isStatusBar | boolean | ||
isToolSettings | boolean | ||
isVisible Accessor ReadOnly | boolean | ||
label Accessor ReadOnly | string | Get the label string | |
priority | number | ||
reactElement Accessor | React.ReactNode | ||
state | WidgetState | ||
stateChanged | boolean | ||
stateFunc | undefined | (state: Readonly<WidgetState>) => WidgetState | ||
syncEventIds | string[] | ||
tooltip Accessor ReadOnly | string | Get the tooltip string | |
widgetControl Accessor ReadOnly | WidgetControl | undefined | ||
widgetType | WidgetType |
Defined in
Last Updated: 13 June, 2024