ToolWidgetProps Interface
Properties for a Tool Widget.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
appButton | undefined | CommandItemDef |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | WidgetProps | Application data attached to the Widget. |
badgeType | undefined | BadgeType | WidgetProps | Badge to be overlaid on the widget tab. |
betaBadge | undefined | false | true | WidgetProps | Indicates whether to draw a Beta badge. |
classId | string | ConfigurableUiControlConstructor | WidgetProps | Control's class id |
control | undefined | ConfigurableUiControlConstructor | WidgetProps | A WidgetControl providing information about the Widget. |
defaultState | undefined | WidgetState | WidgetProps | Default Widget state. |
element | undefined | React.ReactNode | WidgetProps | A React component for the Widget. |
fillZone | undefined | false | true | WidgetProps | Indicates whether this Widget should fill the available space in the Zone. |
horizontalDirection | undefined | Direction | ToolbarWidgetProps | |
horizontalItems | undefined | ItemList | ToolbarWidgetProps | |
iconSpec | string | React.ReactNode | WidgetProps | Specification for icon on Widget Tab |
id | undefined | string | WidgetProps | Optional Id used to uniquely identify the widget. |
isFloatingStateSupported | undefined | false | true | WidgetProps | Indicates if widget can be in floating state. |
isFloatingStateWindowResizable | undefined | false | true | WidgetProps | Indicates if floating widget is resizable. |
isFreeform | undefined | false | true | WidgetProps | Indicates whether the Widget is free-form or rectangular. |
isStatusBar | undefined | false | true | WidgetProps | Indicates whether this Widget is for the Status Bar. |
isToolSettings | undefined | false | true | WidgetProps | Indicates whether this Widget is for the Tool Settings. |
label | string | StringGetter | WidgetProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
labelKey | undefined | string | WidgetProps | if set, it is used to define a key that is used to look up a localized string. |
priority | undefined | number | WidgetProps | Control's priority |
stateFunc | undefined | (state: Readonly<WidgetState>) => WidgetState | WidgetProps | Function executed to determine the state of the widget. |
syncEventIds | undefined | string[] | WidgetProps | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. |
tooltip | string | StringGetter | WidgetProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | WidgetProps | if set, it is used to define a key that is used to look up a localized string. |
verticalDirection | undefined | Direction | ToolbarWidgetProps | |
verticalItems | undefined | ItemList | ToolbarWidgetProps |
Defined in
Last Updated: 13 June, 2024