initialize MethodStatic

Called by the app to initialize the UiFramework

initialize(store: Store<any>, i18n: I18N, oidcConfig?: OidcFrontendClientConfiguration | OidcDesktopClientConfiguration, frameworkStateKey?: string): Promise<any>

Parameter Type Description
store Store<any> The single redux store created by the app.
i18n I18N The internationalization service created by the app.
oidcConfig OidcFrontendClientConfiguration | OidcDesktopClientConfiguration Configuration for authenticating user.
frameworkStateKey string The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed.

Returns - Promise<any>

Defined in

Last Updated: 13 June, 2024