ExpandableSection<SS> Class
Beta
Expandable Section React component used by ListPickerBase
Extends
- PureComponent<ExpandableSectionProps, ExpandableSectionState>
Methods
Name | Description | |
---|---|---|
constructor(props: ExpandableSectionProps): ExpandableSection | Creates an ExpandableSection | |
render(): Element | Renders ExpandableSection |
Inherited methods
Name | Inherited from | Description |
---|---|---|
UNSAFE_componentWillMount(): void Optional | DeprecatedLifecycle | Called immediately before mounting occurs, and before Component#render . |
UNSAFE_componentWillReceiveProps(nextProps: Readonly<ExpandableSectionProps>, nextContext: any): void Optional | DeprecatedLifecycle | Called when the component may be receiving new props. |
UNSAFE_componentWillUpdate(nextProps: Readonly<ExpandableSectionProps>, nextState: Readonly<ExpandableSectionState>, nextContext: any): void Optional | DeprecatedLifecycle | Called immediately before rendering when new props or state is received. |
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional | ComponentLifecycle | Catches exceptions generated in descendant components. |
componentDidMount(): void Optional | ComponentLifecycle | Called immediately after a component is mounted. |
componentDidUpdate(prevProps: Readonly<ExpandableSectionProps>, prevState: Readonly<ExpandableSectionState>, snapshot?: SS): void Optional | NewLifecycle | Called immediately after updating occurs. |
componentWillMount(): void Optional | DeprecatedLifecycle | Called immediately before mounting occurs, and before Component#render . |
componentWillReceiveProps(nextProps: Readonly<ExpandableSectionProps>, nextContext: any): void Optional | DeprecatedLifecycle | Called when the component may be receiving new props. |
componentWillUnmount(): void Optional | ComponentLifecycle | Called immediately before a component is destroyed. |
componentWillUpdate(nextProps: Readonly<ExpandableSectionProps>, nextState: Readonly<ExpandableSectionState>, nextContext: any): void Optional | DeprecatedLifecycle | Called immediately before rendering when new props or state is received. |
getSnapshotBeforeUpdate(prevProps: Readonly<ExpandableSectionProps>, prevState: Readonly<ExpandableSectionState>): SS | null Optional | NewLifecycle | Runs before React applies the result of render to the document, and |
shouldComponentUpdate(nextProps: Readonly<ExpandableSectionProps>, nextState: Readonly<ExpandableSectionState>, nextContext: any): boolean Optional | ComponentLifecycle | Called to determine whether the change in props and state should trigger a re-render. |
Defined in
Last Updated: 13 June, 2024