ConditionalItemDef Class
Beta
An Item that conditionally renders other items based on UiSync events.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ConditionalItemProps): ConditionalItemDef | ||
getVisibleItems(): ActionButtonItemDef[] | ||
handleSyncUiEvent(args: SyncUiEventArgs): boolean | ||
resolveItems(force?: false | true): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
setDescription(v: string | StringGetter): void | ItemDefBase | Set the description. |
setLabel(v: string | StringGetter): void | ItemDefBase | Set the label. |
setTooltip(v: string | StringGetter): void | ItemDefBase | Set the tooltip. |
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static | ItemDefBase |
Properties
Name | Type | Description | |
---|---|---|---|
conditionalId | string | ||
conditionalIdPrefix Static | string | ||
id Accessor ReadOnly | string | ||
items | AnyItemDef[] |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | ItemDefBase | |
badgeType | undefined | BadgeType | ItemDefBase | |
betaBadge | boolean | ItemDefBase | |
description Accessor ReadOnly | string | ItemDefBase | Get the description string |
iconElement | undefined | React.ReactNode | ItemDefBase | |
iconSpec | string | React.ReactNode | ItemDefBase | |
isActive | boolean | ItemDefBase | |
isEnabled | boolean | ItemDefBase | |
isPressed | boolean | ItemDefBase | |
isVisible | boolean | ItemDefBase | |
label Accessor ReadOnly | string | ItemDefBase | Get the label string |
stateFunc | undefined | (state: Readonly<BaseItemState>) => BaseItemState | ItemDefBase | |
stateSyncIds | string[] | ItemDefBase | |
tooltip Accessor ReadOnly | string | ItemDefBase | Get the tooltip string |
trayId Accessor ReadOnly | undefined | ItemDefBase |
Defined in
Last Updated: 13 June, 2024