LabeledToggleProps Interface
Properties for LabeledToggle
Extends
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
buttonType | undefined | ToggleButtonType | ToggleProps | Button type, either Primary or Blue |
className | undefined | string | ClassNameProps | Custom CSS class name |
disabled | undefined | false | true | ToggleProps | Determine if the toggle is disabled or not |
isOn | undefined | false | true | ToggleProps | Determine if the toggle is "on" or "off" |
large | undefined | false | true | ToggleProps | Use larger size |
onBlur | undefined | (event: FocusEvent) => any | ToggleProps | Function called when the toggle loses focus |
onChange | undefined | (checked: boolean) => any | ToggleProps | Function called when the toggle state is changed |
rounded | undefined | false | true | ToggleProps | Show the toggle rounded or square (rounded is default) |
setFocus | undefined | false | true | ToggleProps | Indicates whether to set focus to the input element |
showCheckmark | undefined | false | true | ToggleProps | Show a check mark icon when the toggle is "on" |
style | undefined | React.CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 13 June, 2024