Input<S, SS> Class
Basic text input
Extends
- PureComponent<InputProps>
Methods
Name | Description | |
---|---|---|
componentDidMount(): void | ||
render(): Element |
Inherited methods
Name | Inherited from | Description |
---|---|---|
UNSAFE_componentWillMount(): void Optional | DeprecatedLifecycle | Called immediately before mounting occurs, and before Component#render . |
UNSAFE_componentWillReceiveProps(nextProps: Readonly<InputProps>, nextContext: any): void Optional | DeprecatedLifecycle | Called when the component may be receiving new props. |
UNSAFE_componentWillUpdate(nextProps: Readonly<InputProps>, nextState: Readonly<S>, nextContext: any): void Optional | DeprecatedLifecycle | Called immediately before rendering when new props or state is received. |
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional | ComponentLifecycle | Catches exceptions generated in descendant components. |
componentDidUpdate(prevProps: Readonly<InputProps>, prevState: Readonly<S>, snapshot?: SS): void Optional | NewLifecycle | Called immediately after updating occurs. |
componentWillMount(): void Optional | DeprecatedLifecycle | Called immediately before mounting occurs, and before Component#render . |
componentWillReceiveProps(nextProps: Readonly<InputProps>, nextContext: any): void Optional | DeprecatedLifecycle | Called when the component may be receiving new props. |
componentWillUnmount(): void Optional | ComponentLifecycle | Called immediately before a component is destroyed. |
componentWillUpdate(nextProps: Readonly<InputProps>, nextState: Readonly<S>, nextContext: any): void Optional | DeprecatedLifecycle | Called immediately before rendering when new props or state is received. |
getSnapshotBeforeUpdate(prevProps: Readonly<InputProps>, prevState: Readonly<S>): SS | null Optional | NewLifecycle | Runs before React applies the result of render to the document, and |
shouldComponentUpdate(nextProps: Readonly<InputProps>, nextState: Readonly<S>, nextContext: any): boolean Optional | ComponentLifecycle | Called to determine whether the change in props and state should trigger a re-render. |
Defined in
Last Updated: 13 June, 2024