PrimitivePropertyRenderer<S, SS, S> Class
React Component that renders primitive properties
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
UNSAFE_componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
UNSAFE_componentWillReceiveProps(nextProps: Readonly<PrimitiveRendererProps>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
UNSAFE_componentWillUpdate(nextProps: Readonly<PrimitiveRendererProps>, nextState: Readonly<S>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional |
ComponentLifecycle |
Catches exceptions generated in descendant components. |
componentDidMount(): void Optional |
ComponentLifecycle |
Called immediately after a component is mounted. |
componentDidUpdate(prevProps: Readonly<PrimitiveRendererProps>, prevState: Readonly<S>, snapshot?: SS): void Optional |
NewLifecycle |
Called immediately after updating occurs. |
componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
componentWillReceiveProps(nextProps: Readonly<PrimitiveRendererProps>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
componentWillUnmount(): void Optional |
ComponentLifecycle |
Called immediately before a component is destroyed. |
componentWillUpdate(nextProps: Readonly<PrimitiveRendererProps>, nextState: Readonly<S>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
forceUpdate(callback?: () => void): void |
Component<PrimitiveRendererProps> |
|
getSnapshotBeforeUpdate(prevProps: Readonly<PrimitiveRendererProps>, prevState: Readonly<S>): SS | null Optional |
NewLifecycle |
Runs before React applies the result of render to the document, and |
setState<K extends undefined>(state: (prevState: Readonly<S>, props: Readonly<PrimitiveRendererProps>) => null | S | { T } | null | S | { T }, callback?: () => void): void |
Component<PrimitiveRendererProps> |
|
shouldComponentUpdate(nextProps: Readonly<PrimitiveRendererProps>, nextState: Readonly<S>, nextContext: any): boolean Optional |
ComponentLifecycle |
Called to determine whether the change in props and state should trigger a re-render. |
Inherited properties
Defined in
Last Updated:
13 June, 2024