showLengthEditor Method

Show an input editor for a length value at a particular location.

showLengthEditor(_initialValue: number, _location: XAndY, _onCommit: OnNumberCommitFunc, _onCancel: OnCancelFunc, _htmlElement?: HTMLElement): boolean

Parameter Type Description
_initialValue number Value initially displayed in the editor.
_location XAndY Location of the editor, relative to the origin of htmlElement or the window.
_onCommit OnNumberCommitFunc Function called when the OK button or the Enter key is pressed.
_onCancel OnCancelFunc Function called when the Cancel button or the Escape key is pressed.
_htmlElement HTMLElement The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window.

Returns - boolean

true if the editor was displayed, false if the editor could not be displayed.

Defined in

Last Updated: 13 June, 2024