Content
Types related to presentation content.
Classes
Name | Description | |
---|---|---|
Content | A data structure that contains the Descriptor and a list of Item | |
Descriptor | Data structure that describes content: fields, sorting, filtering, format, etc. | |
Field | Describes a single content field. | |
Item | A data structure that represents a single content record. | |
NestedContentField | Describes a content field that contains Nested content. | |
PropertiesField | Describes a content field that's based on one or more similar |
Enumerations
Name | Description | |
---|---|---|
ContentFlags | Flags that control content format. | |
DefaultContentDisplayTypes | Displayed content types. | |
PropertyValueFormat | Format of the property value. | |
SortDirection | Data sorting direction |
Interfaces
Name | Description | |
---|---|---|
ArrayTypeDescription | Type description for array properties. | |
BaseTypeDescription | Data structure for base content field type description. | |
CategoryDescription | A data structure that describes a Field category. | |
DescriptorOverrides | Descriptor overrides that can be used to customize | |
DescriptorSource | Descriptor properties | |
DisplayValuesArray | An array of display values | |
DisplayValuesMap | A map of display values | |
EditorDescription | A data structure which describes property editor used | |
PrimitiveTypeDescription | Type description for primitive properties. | |
PropertyAccessor | Data structure that describes one step of property | |
SelectClassInfo | Data structure that describes an ECClass in content Descriptor. | |
SelectionInfo | Data structure that contains selection information. | |
StructFieldMemberDescription | A data structure that describes a struct member. | |
StructTypeDescription | Type description for struct properties. | |
ValuesArray | An array of raw values | |
ValuesMap | A map of raw values |
Namespaces
Name | Description | |
---|---|---|
DisplayValue | ||
NestedContentValue | ||
Property | ||
Value |
Type Aliases
Name | Description | |
---|---|---|
PropertyAccessorPath | Describes path to a property. | |
TypeDescription | One of content field type descriptions. |
Last Updated: 13 June, 2024