zoomToPlacementProps Method

Zoom the view to a show the tightest box around a given set of PlacementProps. Optionally, change view rotation.

zoomToPlacementProps(placementProps: PlacementProps[], options?: ViewChangeOptions & ZoomToOptions): void

note any invalid placements are ignored. If no valid placements are supplied, this function does nothing.

Parameter Type Description
placementProps PlacementProps[]  
options ViewChangeOptions & ZoomToOptions options that control how the view change works and whether to change view rotation.

Returns - void

Defined in

Last Updated: 13 June, 2024