overrideSubCategory Method
Customize the way geometry belonging to a SubCategory is drawn by this display style.
overrideSubCategory(id: Id64String, ovr: SubCategoryOverride): void
note If this style is associated with a ViewState attached to a Viewport, use ViewState.overrideSubCategory to ensure the changes are promptly visible on the screen.
see DisplayStyleState.dropSubCategoryOverride
Parameter | Type | Description |
---|---|---|
id | Id64String | The ID of the SubCategory whose appearance is to be overridden. |
ovr | SubCategoryOverride | The overrides to apply to the SubCategoryAppearance. |
Returns - void
Defined in
Last Updated: 13 June, 2024