FuzzySearchResults<T> Class
This class is used to return the results of FuzzySearch.search. It is iterable, with each iteration returning an object implementing the FuzzySearchResult interface.
Implements
- Iterable<T>
Methods
Name | Description | |
---|---|---|
constructor(results: any[] | undefined): FuzzySearchResults | ||
[Symbol.iterator](): any | ||
getResult(resultIndex: number): FuzzySearchResult<T> | undefined |
Properties
Name | Type | Description | |
---|---|---|---|
length Accessor ReadOnly | number | ||
results | any[] |
Defined in
- core/frontend/src/FuzzySearch.ts Line 170
Last Updated: 15 June, 2021