ToolSettingsPropertyItem Class
Deprecated Move ToolSettingsPropertyItem to bentley/ui-abstract beginning in iModel.js 2.0.
Beta
Class used to identify a specific ToolSettings property value. This is the minimal amount of info necessary to specify which property a value is associated with. This is used to both display property in UI, save and retrieve the state of the property, and to allow the UI to inform the Tool code about property changes.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(value: ToolSettingsValue, propertyName: string): ToolSettingsPropertyItem |
Properties
Name | Type | Description | |
---|---|---|---|
propertyName | string | ||
value | ToolSettingsValue |
Defined in
Last Updated: 13 June, 2024