constructor Method

Constructor

NotifyMessageDetails(priority: OutputMessagePriority, briefMessage: HTMLElement | string, detailedMessage?: HTMLElement | string, msgType: OutputMessageType = OutputMessageType.Toast, openAlert: OutputMessageAlert = OutputMessageAlert.None): NotifyMessageDetails

Parameter Type Description
priority OutputMessagePriority The priority this message should be accorded by the NotificationManager.
briefMessage HTMLElement | string  
detailedMessage HTMLElement | string  
msgType OutputMessageType The type of message.
openAlert OutputMessageAlert Whether an alert box should be displayed or not, and if so what kind.

Returns - NotifyMessageDetails

Defined in

Last Updated: 13 June, 2024