ViewDetails3d Class
Beta
Encapsulates access to optional 3d view details stored in JSON properties.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allow3dManipulations Accessor | boolean | Controls whether viewing tools are allowed to operate on the view in 3 dimensions. | Beta |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
aspectRatioSkew Accessor | number | ViewDetails | The aspect ratio skew (x/y, usually 1.0) used to exaggerate the y axis of the view. |
auxiliaryCoordinateSystemId Accessor | Id64String | ViewDetails | The Id of the auxiliary coordinate system for the view. |
clipVector Accessor | ClipVector | undefined | ViewDetails | Clipping volume for the view. |
gridOrientation Accessor | GridOrientationType | ViewDetails | The orientation of the view's grid. |
gridSpacing Accessor | XAndY | ViewDetails | The grid spacing for the view. |
gridsPerRef Accessor | number | ViewDetails | The number of grids per ref for the view. |
Defined in
- core/common/src/ViewDetails.ts Line 156
Last Updated: 13 June, 2024