GeometricModel2dProps Interface
Properties that define a GeometricModel2d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
globalOrigin | undefined | XYProps | The actual coordinates of (0,0) in modeling coordinates. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
geometryGuid | undefined | GuidString | GeometricModelProps | A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model |
id | undefined | Id64String | EntityProps | The Id of the entity. |
isPrivate | undefined | false | true | ModelProps | |
isTemplate | undefined | false | true | ModelProps | |
jsonProperties | undefined | any | ModelProps | |
modeledElement | RelatedElementProps | ModelProps | |
name | undefined | string | ModelProps | |
parentModel | undefined | Id64String | ModelProps |
Defined in
- core/common/src/ModelProps.ts Line 49
Last Updated: 13 June, 2024