setupOptionDefaults MethodProtected
Augment request options with defaults returned by the DefaultIModelHubRequestOptionsProvider. Note that the options passed in by clients override any defaults where necessary.
setupOptionDefaults(options: RequestOptions): Promise<void>
Parameter | Type | Description |
---|---|---|
options | RequestOptions | Options the caller wants to augment with the defaults. |
Returns - Promise<void>
Promise resolves after the defaults are setup.
Defined in
Last Updated: 13 June, 2024