ChangeSet Class
Beta
ChangeSet represents a file containing changes to the iModel. A single ChangeSet contains changes made on a single Briefcase file and pushed as a single file. ChangeSets form a linear change history of the iModel. If a user wants to push their changes to iModelHub, they first have to merge all ChangeSet they do not have yet. Only a single briefcase is allowed to push their changes at a time.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationId | undefined | string | Id of the application that created this ChangeSet. | |
applicationName | undefined | string | Name of the application that created this ChangeSet. | |
bridgeChangedFiles | undefined | string[] | File names which have been modified with this ChangeSet. | |
bridgeJobId | undefined | string | Id of the bridge that created this ChangeSet. | |
bridgeUsers | undefined | string[] | User identifiers of users who made changes contained in this ChangeSet. | |
briefcaseId | undefined | number | Id of the Briefcase that pushed this ChangeSet. | |
changesType | undefined | ChangesType | Shows what kind of changes are contained in this ChangeSet. | |
description | undefined | string | Description of this ChangeSet. | |
downloadUrl | undefined | string | URL from where the ChangeSet file can be downloaded. | |
fileName | undefined | string | Filename of the ChangeSet. | |
fileSize | undefined | string | Size of this ChangeSet file. | |
id | undefined | string | Id of this ChangeSet. | |
index | undefined | string | Index of this ChangeSet (increasing, but not necessarily sequential). | |
isUploaded | undefined | false | true | Flag that needs to be marked true, when confirming successful ChangeSet upload. | |
parentId | undefined | string | Id of this ChangeSet's parent ChangeSet. | |
pathname | undefined | string | Path to the download ChangeSet file on disk. | |
pushDate | undefined | string | Date when this ChangeSet was pushed to iModelHub. | |
seedFileId | undefined | GuidString | Id of the file that this ChangeSet belongs to. | |
uploadUrl | undefined | string | URL where the ChangeSet file has to be uploaded. | |
userCreated | undefined | string | Id of the user that pushed this ChangeSet. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
changeState | undefined | ChangeState | WsgInstance | |
ecId | string | ECInstance | |
eTag | undefined | string | WsgInstance | |
wsgId | string | WsgInstance |
Defined in
Last Updated: 13 June, 2024