create MethodStatic
Create a DisplayStyle2d for use by a ViewDefinition.
create(iModelDb: IModelDb, definitionModelId: Id64String, name: string): DisplayStyle2d
throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | Id64String | The DefinitionModel |
name | string | The name/CodeValue of the DisplayStyle2d |
Returns - DisplayStyle2d
The newly constructed DisplayStyle2d element.
Defined in
- core/backend/src/ViewDefinition.ts Line 143
Last Updated: 13 June, 2024