createSnapshot MethodStatic

Beta  

Create an empty local Snapshot iModel file. Snapshots are not synchronized with iModelHub, so do not have a change timeline.

Note: A snapshot cannot be modified after IModelDb.closeSnapshot is called.

createSnapshot(snapshotFile: string, args: CreateIModelProps): IModelDb

see Snapshot iModels

Parameter Type Description
snapshotFile string The file that will contain the new iModel snapshot
args CreateIModelProps The parameters that define the new iModel snapshot

Returns - IModelDb

Defined in

Last Updated: 13 June, 2024