ExportPartInstanceInfo Interface
Information about references to GeometryPart elements found during a call to IModelDb.exportGraphics. See IModelDb.exportPartGraphics for the intended use case.
Properties
Name | Type | Description | |
---|---|---|---|
displayProps | ExportPartDisplayInfo | The base display properties when the GeometryPart was referenced. | |
partId | Id64String | ID for the GeometryPart | |
partInstanceId | Id64String | ID for the element that contained the reference to the GeometryPart | |
transform | undefined | Float64Array | A row-major storage 4x3 transform for this instance. |
Defined in
- core/backend/src/ExportGraphics.ts Line 125
Last Updated: 13 June, 2024