ExternalSourceAspect Class
An ElementMultiAspect that stores synchronization information for an Element originating from an external source.
note The associated ECClass was added to the BisCore schema in version 1.0.2
Extends
Implements
Inherited methods
Name | Inherited from | Description |
---|---|---|
forEachProperty(func: PropertyCallback, includeCustom: boolean = false): void | Entity | Call a function for each property of this Entity. |
onDelete(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called before an ElementAspect is deleted. |
onDeleted(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called after an ElementAspect was deleted. |
onInsert(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called before a new ElementAspect is inserted. |
onInserted(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called after a new ElementAspect was inserted. |
onUpdate(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called before an ElementAspect is updated. |
onUpdated(_props: ElementAspectProps, _iModel: IModelDb): void ProtectedStatic | ElementAspect | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
checksum | undefined | string | The cryptographic hash (any algorithm) of the source object's content. | |
identifier | string | The identifier of the object in the source repository. | |
jsonProperties | undefined | string | A place where additional JSON properties can be stored. | |
kind | string | The kind of object within the source repository. | |
scope | RelatedElement | An element that scopes the combination of kind and identifier to uniquely identify the object from the external source. |
|
version | undefined | string | An optional value that is typically a version number or a pseudo version number like last modified time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | Entity | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | Entity | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | Entity | The name of the BIS class associated with this class. |
element | RelatedElement | ElementAspect | |
id | Id64String | Entity | The Id of this Entity. |
iModel | IModelDb | Entity | The IModelDb that contains this Entity |
schema Static | undefined | Entity | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | Entity | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 13 June, 2024