strokeConstantVSection Method

return strokes for a cross-section (elliptic arc) at specified fraction v along the axis.

  • fixedStrokeCount takes priority over stroke options.
  • The linestring is created by LineString3d.createForStrokes (fixedStrokeCount, options), which sets up property according to the options:
    • optional fractions member
    • optional uvParams. uvParams are installed as full-scale distance parameters.
    • optional derivatives.

strokeConstantVSection(v: number, fixedStrokeCount: number | undefined, options: StrokeOptions | undefined): LineString3d

Parameter Type Description
v number fractional position along the cone axis
fixedStrokeCount number | undefined optional stroke count.
options StrokeOptions | undefined optional stroke options.

Returns - LineString3d

Defined in

Last Updated: 13 June, 2024