interpolate Method
Return a vector computed at fractional position between this vector and vectorB
interpolate(fraction: number, vectorB: Vector3d, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
fraction | number | fractional position. 0 is at this . 1 is at vectorB . True fractions are "between", negatives are "before this", beyond 1 is "beyond vectorB". |
vectorB | Vector3d | second vector |
result | Vector3d | optional preallocated result. |
Returns - Vector3d
Defined in
Last Updated: 13 June, 2024