solveTrigForm MethodStatic

return the 0, 1, or 2 pairs of (c,s) values that solve {constCoff + cosCoff * c + sinCoff * s = } with the constraint {cc+ss = 1}

solveTrigForm(constCoff: number, cosCoff: number, sinCoff: number): Vector2d[] | undefined

Parameter Type Description
constCoff number  
cosCoff number  
sinCoff number  

Returns - Vector2d[] | undefined

Defined in

Last Updated: 13 June, 2024