angleToSignedPeriodicFraction Method

map an angle to a fractional coordinate which is:

  • the start angle is at fraction 0
  • the end angle is at fraction 1
  • interior angles are between 0 and 1
  • small negative for angles just "before" the start angle
  • more than one for angles just "after" the end angle
  • the periodic jump is at the middle of the "outside" interval

angleToSignedPeriodicFraction(theta: Angle): number

Parameter Type Description
theta Angle  

Returns - number

Defined in

Last Updated: 13 June, 2024