computeSelection Method
Computes keys that need to be added to logical selection based on provided selection scope.
computeSelection(imodel: IModelConnection, ids: Id64Arg, scope: string | SelectionScopeProps | SelectionScope): Promise<KeySet>
Parameter | Type | Description |
---|---|---|
imodel | IModelConnection | |
ids | Id64Arg | Element IDs to compute selection for |
scope | string | SelectionScopeProps | SelectionScope | Selection scope to apply |
Returns - Promise<KeySet>
Defined in
Last Updated: 20 June, 2023