removeFromSelectionWithScope Method
Remove keys from current selection after applying selection scope on them.
removeFromSelectionWithScope(source: string, imodel: IModelConnection, ids: Id64Arg, scope: string | SelectionScopeProps | SelectionScope, level: number = 0, rulesetId?: string): Promise<void>
Parameter | Type | Description |
---|---|---|
source | string | Name of the selection source |
imodel | IModelConnection | iModel associated with the selection |
ids | Id64Arg | Element IDs to remove |
scope | string | SelectionScopeProps | SelectionScope | Selection scope to apply |
level | number | Selection level (see selection levels documentation section) |
rulesetId | string | ID of the ruleset in case the selection was changed from a rules-driven control |
Returns - Promise<void>
Defined in
Last Updated: 20 June, 2023