SelectionChangeEventArgs Interface
The event object that's sent when the selection changes.
Properties
Name | Type | Description | |
---|---|---|---|
changeType | SelectionChangeType | The selection change type. | |
imodel | IModelConnection | iModel connection with which the selection is associated with. | |
keys | Readonly<KeySet> | Set of keys affected by this selection change event. | |
level | number | Level of the selection. | |
rulesetId | undefined | string | Id of the ruleset associated with the selection change. | |
source | string | The name of the selection source which caused the selection change. | |
timestamp | Date | The timestamp of when the selection change happened |
Defined in
Last Updated: 20 June, 2023