add Method
Adds favorite properties into a certain scope.
add(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): Promise<void>
note initializeConnection
must be called with the imodel
before calling this function.
Parameter | Type | Description |
---|---|---|
field | Field | Field that contains properties. If field contains multiple properties, all of them will be favorited. |
imodel | IModelConnection | IModelConnection. |
scope | FavoritePropertiesScope | FavoritePropertiesScope to put the favorite properties into. |
Returns - Promise<void>
Defined in
- presentation/frontend/src/presentation-frontend/favorite-properties/FavoritePropertiesManager.ts Line 165
Last Updated: 20 June, 2023