FavoritePropertiesDataFiltererProps Interface
Props for FavoritePropertiesDataFilterer.
Methods
Name | Description | |
---|---|---|
isFavorite(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): boolean Optional | Callback to check whether a property is favorite or not. |
Properties
Name | Type | Description | |
---|---|---|---|
favoritesScope | FavoritePropertiesScope | Scope used to determine favorite properties | |
isActive | undefined | boolean | Should the filterer become active when created. | |
source | IPresentationPropertyDataProvider | Source properties data provider |
Defined in
- presentation/components/src/presentation-components/propertygrid/FavoritePropertiesDataFilterer.ts Line 20
Last Updated: 20 June, 2023