StringQuerySpecification Interface
The specification contains an ECSQL query which is used to query for instances.
see String query specification reference documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
query | string | Specifies the search ECSQL query. | |
specType | "String" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
class | SingleSchemaClassSpecification | QuerySpecificationBase | Specification of ECClass whose instances the query returns. |
Defined in
- presentation/common/src/presentation-common/rules/hierarchy/CustomQueryInstanceNodesSpecification.ts Line 71
Last Updated: 20 June, 2023